summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-22 10:39:08 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-22 10:39:08 +0200
commite64ea84392ca85d1ef23ebc5e4c1ec759f29b8cd (patch)
tree7e03971158a5dc313f87aecadfcedfee8a0d9317 /gnu/packages/python-xyz.scm
parent34bf3ed26b76d2978b2b0134676225e159c1d984 (diff)
downloadguix-e64ea84392ca85d1ef23ebc5e4c1ec759f29b8cd.tar.gz
gnu: python-bleach: Update to 3.1.3 (fixes CVE-2020-6816).
* gnu/packages/python-xyz.scm (python-bleach): Update to 3.1.3.
[native-inputs]: Remove python-pytest-runner2. Add python-datrie,
python-genshi, python-lxml.
[home-page]: Update to new home-page.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d2a3329dfb..65bc6df4aa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8197,22 +8197,24 @@ Jupyter Notebook format and Python APIs for working with notebooks.")
 (define-public python-bleach
   (package
     (name "python-bleach")
-    (version "3.1.1")
+    (version "3.1.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "bleach" version))
        (sha256
         (base32
-         "0j4xlnw99m1xy0s7wxz9fk5f3c1n8r296fh75jn5p5j61w6qg2xa"))))
+         "0al437aw4p2xp83az5hhlrp913nsf0cg6kg4qj3fjhv4wakxipzq"))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-webencodings" ,python-webencodings)
        ("python-six" ,python-six)))
     (native-inputs
-     `(("python-pytest" ,python-pytest)
-       ("python-pytest-runner" ,python-pytest-runner-2)))
-    (home-page "https://github.com/jsocol/bleach")
+     `(("python-datrie" ,python-datrie)
+       ("python-genshi" ,python-genshi)
+       ("python-lxml" ,python-lxml)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/mozilla/bleach")
     (synopsis "Whitelist-based HTML-sanitizing tool")
     (description "Bleach is an easy whitelist-based HTML-sanitizing tool.")
     (license license:asl2.0)))