summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-27 11:10:01 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-27 17:01:20 +0200
commit6ac6a7e0202e536b42756413d464f98e0c02f5c1 (patch)
tree72c517ed606933e03b472bc3d5d4aaeb43007c29 /gnu/packages/python-xyz.scm
parent0d41fe4855588fb659b8adafe215d5573517a79b (diff)
downloadguix-6ac6a7e0202e536b42756413d464f98e0c02f5c1.tar.gz
gnu: file: Update to 5.41.
* gnu/packages/file.scm (file): Absorb file-next.
* gnu/packages/commencement.scm (file-boot0)[arguments]: Add make-flag
to set CFLAGS.
* gnu/packages/diffoscope.scm (diffoscope): Remove file-next.
* gnu/packages/python-xyz.scm (python-magic)[inputs]: Replace file-next
with file.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c8ba314d38..3bd382e12d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15304,9 +15304,7 @@ syntax highlighting, markdown and more to the terminal.")
      (list which))
     (inputs
      ;; python-magic needs to be able to find libmagic.so.
-     ;; Use a newer version because 5.39 returns bogus for some archives
-     ;; (notably Chromium .crx extensions), which breaks e.g. 'diffoscope'.
-     (list file-next))
+     (list file))
     (synopsis "File type identification using libmagic")
     (description
      "This module uses ctypes to access the libmagic file type