summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-06 21:53:32 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-06 22:02:15 +0200
commitb949f34f31a045eb0fb242b81a223178fb6994d3 (patch)
tree837a94d9d642039f46ce071b8ac1adbb805b3a71 /gnu/packages/python-xyz.scm
parent3dc8052b51241fe7857059d3300dad3a0f9f68fd (diff)
downloadguix-b949f34f31a045eb0fb242b81a223178fb6994d3.tar.gz
gnu: Use the non-deprecated TeX packages.
This commit leaves 'dblatex' and 'texlive-hyperref' as users of
deprecated packages, but these have many dependents.

* gnu/packages/bioinformatics.scm (discrover)[native-inputs]: Use
non-deprecated TeX Live packages.
(velvet)[native-inputs]: Likewise.
* gnu/packages/chez.scm (chez-scheme)[native-inputs]: Likewise.
(chez-web)[native-inputs]: Likewise.
* gnu/packages/engineering.scm (fastcap)[native-inputs]: Likewise.
* gnu/packages/guile-xyz.scm (emacsy)[native-inputs]: Likewise.
* gnu/packages/maths.scm (hypre)[native-inputs]: Likewise.
* gnu/packages/music.scm (lilypond)[native-inputs]: Likewise.
* gnu/packages/ocaml.scm (ocaml-bibtex2html)[native-inputs]: Likewise.
* gnu/packages/plotutils.scm (asymptote)[native-inputs]: Likewise.
* gnu/packages/python-xyz.scm (python-numpy-documentation)[native-inputs]:
Likewise.
(python-matplotlib-documentation)[native-inputs]: Likewise.
(python-ipython-documentation)[native-inputs]: Likewise.
(python-nbconvert)[native-inputs]: Likewise.
(python-pypandoc)[native-inputs]: Likewise.
* gnu/packages/statistics.scm (r-with-tests)[native-inputs]: Likewise.
* gnu/packages/tex.scm (texlive-pstool)[propagated-inputs]: Likewise.
(teximpatient)[native-inputs]: Likewise.
(texlive-latex-pgf)[propagated-inputs]: Likewise.
(texlive-beamer)[propagated-inputs]: Likewise.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm42
1 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index acc7910f32..9801a3caf8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5287,16 +5287,16 @@ color scales, and color space conversion easy.  It has support for:
        ("pkg-config" ,pkg-config)
        ("python-sphinx" ,python-sphinx)
        ("python-numpydoc" ,python-numpydoc)
-       ("texlive" ,(texlive-updmap.cfg (list texlive-fonts-cm-super
+       ("texlive" ,(texlive-updmap.cfg (list texlive-cm-super
                                         texlive-fonts-ec
-                                        texlive-generic-ifxetex
-                                        texlive-generic-pdftex
+                                        texlive-generic-iftex
+                                        texlive-pdftex
                                         texlive-amsfonts
                                         texlive-latex-capt-of
                                         texlive-latex-cmap
                                         texlive-latex-environ
                                         texlive-latex-eqparbox
-                                        texlive-latex-etoolbox
+                                        texlive-etoolbox
                                         texlive-latex-expdlist
                                         texlive-latex-fancyhdr
                                         texlive-latex-fancyvrb
@@ -5305,11 +5305,11 @@ color scales, and color space conversion easy.  It has support for:
                                         texlive-latex-framed
                                         texlive-latex-geometry
                                         texlive-latex-graphics
-                                        texlive-latex-hyperref
+                                        texlive-hyperref
                                         texlive-latex-mdwtools
                                         texlive-latex-multirow
                                         texlive-latex-needspace
-                                        texlive-latex-oberdiek
+                                        texlive-oberdiek
                                         texlive-latex-parskip
                                         texlive-latex-preview
                                         texlive-latex-tabulary
@@ -5318,7 +5318,7 @@ color scales, and color space conversion easy.  It has support for:
                                         texlive-latex-trimspaces
                                         texlive-latex-ucs
                                         texlive-latex-upquote
-                                        texlive-latex-url
+                                        texlive-url
                                         texlive-latex-varwidth
                                         texlive-latex-wrapfig)))
        ("texinfo" ,texinfo)
@@ -5842,11 +5842,11 @@ toolkits.")
                                         texlive-latex-type1cm
                                         texlive-latex-ucs
 
-                                        texlive-generic-pdftex
+                                        texlive-pdftex
 
                                         texlive-fonts-ec
-                                        texlive-fonts-adobe-times
-                                        texlive-fonts-txfonts)))
+                                        texlive-times
+                                        texlive-txfonts)))
        ("texinfo" ,texinfo)
        ,@(package-native-inputs python-matplotlib)))
     (arguments
@@ -8134,13 +8134,13 @@ computing.")
        ;; FIXME: It's possible that a smaller union would work just as well.
        ("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
                                         texlive-fonts-ec
-                                        texlive-generic-ifxetex
+                                        texlive-generic-iftex
                                         texlive-pdftex
                                         texlive-latex-capt-of
                                         texlive-latex-cmap
                                         texlive-latex-environ
                                         texlive-latex-eqparbox
-                                        texlive-latex-etoolbox
+                                        texlive-etoolbox
                                         texlive-latex-expdlist
                                         texlive-latex-fancyhdr
                                         texlive-latex-fancyvrb
@@ -8149,11 +8149,11 @@ computing.")
                                         texlive-latex-framed
                                         texlive-latex-geometry
                                         texlive-latex-graphics
-                                        texlive-latex-hyperref
+                                        texlive-hyperref
                                         texlive-latex-mdwtools
                                         texlive-latex-multirow
                                         texlive-latex-needspace
-                                        texlive-latex-oberdiek
+                                        texlive-oberdiek
                                         texlive-latex-parskip
                                         texlive-latex-preview
                                         texlive-latex-tabulary
@@ -8162,7 +8162,7 @@ computing.")
                                         texlive-latex-trimspaces
                                         texlive-latex-ucs
                                         texlive-latex-upquote
-                                        texlive-latex-url
+                                        texlive-url
                                         texlive-latex-varwidth
                                         texlive-latex-wrapfig)))
        ("texinfo" ,texinfo)))))
@@ -11198,18 +11198,18 @@ time.")
                                         texlive-eurosym
                                         texlive-fonts-rsfs
                                         texlive-generic-ulem
-                                        texlive-iftex
+                                        texlive-generic-iftex
                                         texlive-jknappen
                                         texlive-latex-amsmath
                                         texlive-latex-enumitem
                                         texlive-latex-fancyvrb
                                         texlive-latex-float
-                                        texlive-latex-fontspec
+                                        texlive-fontspec
                                         texlive-latex-geometry
-                                        texlive-latex-hyperref
+                                        texlive-hyperref
                                         texlive-latex-jknapltx
                                         texlive-latex-ms
-                                        texlive-latex-oberdiek
+                                        texlive-oberdiek
                                         texlive-latex-parskip
                                         texlive-latex-trimspaces
                                         texlive-latex-upquote
@@ -24948,8 +24948,8 @@ By default it uses the open Python vulnerability database Safety DB.")
     (native-inputs
      `(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
                                         texlive-fonts-ec
-                                        texlive-latex-hyperref
-                                        texlive-latex-oberdiek
+                                        texlive-hyperref
+                                        texlive-oberdiek
                                         texlive-lm
                                         texlive-xcolor)))))
     (arguments