summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-07-25 08:39:23 -0400
committerLudovic Courtès <ludo@gnu.org>2022-08-01 14:08:09 +0200
commitd7ab54cdb1021e003bb335baa2aee9cc32d747c7 (patch)
tree5796c37b87f20e025136fe62a939cb26933dd9dc /gnu/packages/python-xyz.scm
parentdd3cf144028ccd4e12b32133846525e97101d9cd (diff)
downloadguix-d7ab54cdb1021e003bb335baa2aee9cc32d747c7.tar.gz
gnu: Add python-biblib.
* gnu/packages/python-xyz.scm (python-biblib): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8f409a4b7d..6fd18bfa35 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -124,6 +124,7 @@
 ;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
+;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -30203,3 +30204,32 @@ versa.  Extended WKB/WKT are also supported.")
 binary diff utility.  It also provides two command-line tools, @code{bsdiff4}
 and @code{bspatch4}.")
     (license license:bsd-2)))
+
+(define-public python-biblib
+  (let ((upstream-version "0.1.0")
+        (commit "ab0e857b9198fe425ec9b02fcc293b5d9fd0c406")
+        (revision "1"))
+    (package
+      (name "python-biblib")
+      (version (git-version upstream-version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/aclements/biblib")
+               (commit commit)))
+         (sha256
+          (base32 "1ym1gwxys9gl5a7fjs6xh5z9w50pnq4z3rs6fx7kpv78hlrbjlip"))
+         (file-name (git-file-name name version))))
+      (build-system python-build-system)
+      (home-page "https://github.com/aclements/biblib")
+      (synopsis "BibTeX parsing and transformation library")
+      (description
+       "Biblib provides a simple, standalone Python 3 package for parsing
+BibTeX bibliographic databases, as well as algorithms for manipulating BibTeX
+entries in BibTeX-y ways.  Biblib's parser is derived directly from the WEB
+source code for BibTeX and hence (barring bugs in translation) should be fully
+compatible with BibTeX's own parser.")
+      ;; N.B. It seems the parser was translated from WEB by hand: this
+      ;; package does not contain any generated files.
+      (license license:expat))))