summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2019-10-28 15:41:32 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-29 08:38:26 +0100
commitaee92957b5032196cb830f0288557de864c9c644 (patch)
treef8a9185f3ee317947ee52f64bd119ff9edcf7761 /gnu/packages/python-xyz.scm
parent0bb322014084ee76f193bbc3348f29479f014e23 (diff)
downloadguix-aee92957b5032196cb830f0288557de864c9c644.tar.gz
gnu: Add python-memcached.
* gnu/packages/python-xyz.scm (python-memcached): New public variable.

Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index edca719547..e082351e36 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10664,6 +10664,28 @@ implementation as been adapted, improved and fixed from Molten.")
 running in.")
     (license license:isc)))
 
+(define-public python-memcached
+  (package
+    (name "python-memcached")
+    (version "1.59")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-memcached" version))
+       (sha256
+        (base32
+         "0kvyapavbirk2x3n1jx4yb9nyigrj1s3x15nm3qhpvhkpqvqdqm2"))))
+    (build-system python-build-system)
+    (propagated-inputs `(("python-six" ,python-six)))
+    (home-page
+     "https://github.com/linsomniac/python-memcached")
+    (synopsis "Pure python memcached client")
+    (description
+     "This software is a pure Python interface to the memcached memory cache
+daemon.  It is the client side software which allows storing values in one or
+more, possibly remote, memcached servers.")
+    (license license:psfl)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")