summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-13 17:11:09 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-13 17:11:09 +0100
commit70daf82f2835fbcb9da61818a167c302ec6c0512 (patch)
tree6e2b41e6e326d82427eb9fabaa9433a7d90c8022 /gnu/packages/python-xyz.scm
parent3942bf5e4ca175313102a24570212aadc3d1337e (diff)
downloadguix-70daf82f2835fbcb9da61818a167c302ec6c0512.tar.gz
gnu: Add python2-argparse.
* gnu/packages/python-xyz.scm (python2-argparse): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1f48c33222..8be5f390a9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11649,6 +11649,27 @@ applications in seconds while maintaining all the flexibility.")
 (define-public python2-mando
   (package-with-python2 python-mando))
 
+(define-public python2-argparse
+  (package
+    (name "python2-argparse")
+    (version "1.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "argparse" version))
+       (sha256
+        (base32
+         "1r6nznp64j68ih1k537wms7h57nvppq0szmwsaf99n71bfjqkc32"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2))
+    (home-page "https://github.com/ThomasWaldmann/argparse/")
+    (synopsis "Python command-line parsing library")
+    (description
+     "This package is mostly for people who want to have @code{argparse} on
+older Pythons because it was not part of the standard library back then.")
+    (license license:psfl)))
+
 (define-public python-fudge
   (package
     (name "python-fudge")