summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2019-10-28 15:41:34 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-29 08:38:28 +0100
commitc6f008d6266a443344ce89e222c9534b2056d806 (patch)
tree36db0812b55e704e314e4ed77f401964dafd14b9 /gnu/packages/python-xyz.scm
parentb2ac2508b09f264b11721fa42edefd2b96ac6476 (diff)
downloadguix-c6f008d6266a443344ce89e222c9534b2056d806.tar.gz
gnu: Add python-msgpack-python.
* gnu/packages/python-xyz.scm (python-msgpack-python): New public variable.

Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 00bc41083a..c518783bb0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10708,6 +10708,27 @@ more, possibly remote, memcached servers.")
 interfaces.")
     (license license:expat)))
 
+(define-public python-msgpack-python
+  (package
+    (name "python-msgpack-python")
+    (version "0.5.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "msgpack-python" version))
+       (sha256
+        (base32
+         "16wh8qgybmfh4pjp8vfv78mdlkxfmcasg78lzlnm6nslsfkci31p"))))
+    (build-system python-build-system)
+    (home-page "http://msgpack.org/")
+    (synopsis "Package to deserialize messages in MessagePack binary format")
+    (description
+     "MessagePack is an efficient binary serialization format.  It lets you
+exchange data among multiple languages like JSON.  But it's faster and
+smaller.  Small integers are encoded into a single byte, and typical short
+strings require only one extra byte in addition to the strings themselves.")
+    (license license:asl2.0)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")