summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-24 00:41:12 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:54 -0500
commit5271099e824ce0650c9efc9dd536e2806a7b30b2 (patch)
treef2f3258c93cf1fc2d21d16ee5b20f9c5a0412575 /gnu/packages/python-xyz.scm
parent423734264615f0bed8d92a0ebb8ef563ac7c2936 (diff)
downloadguix-5271099e824ce0650c9efc9dd536e2806a7b30b2.tar.gz
gnu: python-pygithub: Do not set PYTHONPATH.
* gnu/packages/python-xyz.scm (python-pygithub): Delete trailing #t.
[phases]{check}: Do not set PYTHONPATH.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9a64fae345..8ecf057166 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3616,17 +3616,14 @@ to deprecate classes, functions or methods.")
                   (add-after 'unpack 'disable-failing-tests
                     (lambda _
                       (substitute* "tests/Issue142.py"
-                        (("testDecodeJson") "disabled_testDecodeJson"))
-                      #t))
+                        (("testDecodeJson")
+                         "disabled_testDecodeJson"))))
                   (add-before 'check 'prepare-for-tests
                     (lambda _
                       (for-each (lambda (f)
                                   (chmod f #o666))
                                 (find-files "./tests"))
-                      (system* "python" "-m" "lib2to3" "-w" "-n" "tests")
-                      (setenv "PYTHONPATH"
-                              (string-append "./tests:" (getenv "PYTHONPATH")))
-                      #t)))))
+                      (system* "python" "-m" "lib2to3" "-w" "-n" "tests"))))))
     (propagated-inputs
      `(("python-deprecated" ,python-deprecated)
        ("python-pyjwt" ,python-pyjwt)