summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-18 18:12:50 +0100
committerMarius Bakke <marius@gnu.org>2022-01-18 19:35:56 +0100
commite31ff150f938ae5f61d93c30847555eed91e58c0 (patch)
tree5e7e5ba1bb79a2d86280c7062e006e868236e66a /gnu/packages/python-xyz.scm
parent2188af8bdff0ac74e216840ac46cf1580f23f66a (diff)
downloadguix-e31ff150f938ae5f61d93c30847555eed91e58c0.tar.gz
gnu: python-peachpy: Fix build.
* gnu/packages/python-xyz.scm (python-peachpy)[arguments]: Invoke nosetests
directly.
[native-inputs]: Add PYTHON-SETUPTOOLS.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 49c4bd848b..8bbbd950cd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27541,9 +27541,9 @@ and BMI2).")
                     (replace 'check
                       (lambda* (#:key tests? #:allow-other-keys)
                         (when tests?
-                          (invoke "python" "setup.py" "nosetests")))))))
+                          (invoke "nosetests")))))))
       (native-inputs
-       (list python-nose python-rednose))
+       (list python-nose python-rednose python-setuptools))
       (propagated-inputs
        (list python-six python-opcodes))
       (synopsis "Efficient assembly code generation in Python")