summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-21 15:52:25 +0200
committerMarius Bakke <marius@gnu.org>2022-06-21 17:30:44 +0200
commita358602d35e71cbde9d390beeeebc08543ab3414 (patch)
tree8f60e27eeba89b3b488ff19c9a0734a8971a7a13 /gnu/packages/python-xyz.scm
parent41bf90f96630f890724438e4ab5819d410a96036 (diff)
downloadguix-a358602d35e71cbde9d390beeeebc08543ab3414.tar.gz
gnu: python-ipython-sql: Update to 0.4.1.
* gnu/packages/python-xyz.scm (python-ipython-sql): Update to 0.4.1.
[arguments]: Remove #:phases.  Add #:tests?.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 11c50a762b..0fe436cbe5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8298,25 +8298,16 @@ cluster down and deletes the throwaway profile.")
 (define-public python-ipython-sql
   (package
     (name "python-ipython-sql")
-    (version "0.4.0")
+    (version "0.4.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "ipython-sql" version))
        (sha256
-        (base32 "0v74ayc6vw98f4jljmwy45qpqbcbhlrb4g1qdyypq9sppxcqx21y"))))
+        (base32 "1r6rz8jgrqzhkf2flwjw75d96g8l7kykmx5wli3q1988w96391ip"))))
     (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-build
-           (lambda _
-             ;; The "NEWS.rst" file is missing from the PyPI distribution.
-             ;; (see: https://github.com/catherinedevlin/ipython-sql/issues/164)
-             (substitute* "setup.py"
-               (("NEWS = [^\n]*") "")
-               (("long_description=README \\+ '\\\\n\\\\n' \\+ NEWS,")
-                "long_description=README,")))))))
+    ;; Tests must run under IPython.
+    (arguments '(#:tests? #f))
     (propagated-inputs
      (list python-ipython
            python-ipython-genutils