summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-08-21 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-08-21 02:00:11 +0200
commitb5c07581c4df0f49807fdbf43ba257bcb57b96a6 (patch)
treee270daa0a2f620efe956cf1cf790cdd2411ea84c /gnu/packages/python-xyz.scm
parentff3cecffafad0ddf5cc2af6cb676e73bcf58e431 (diff)
downloadguix-b5c07581c4df0f49807fdbf43ba257bcb57b96a6.tar.gz
gnu: python-jaraco-functools: Disable flaky test.
* gnu/packages/python-xyz.scm (python-jaraco-functools)[arguments]:
Skip the "test_function_throttled".

Reported by Lumine in #guix.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 079e087b10..542f90ae29 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8337,8 +8337,11 @@ module with a few extra procedures.")
               (lambda* (#:key tests? #:allow-other-keys)
                 (when tests?
                   ;; Do not test the myproject.toml build as it tries to pull
-                  ;; dependencies from the Internet.
-                  (invoke "pytest" "-vv" "-k" "not project"))))))))
+                  ;; dependencies from the Internet.  Do not run a test that
+                  ;; tries to emulate a broken proprietary CI set-up, fails
+                  ;; to do so correctly, and then throws an error about it.
+                  (invoke "pytest" "-vv" "-k"
+                          "not project and not test_function_throttled"))))))))
     (native-inputs
      (modify-inputs
          (package-native-inputs python-jaraco-functools-bootstrap)