summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-28 10:47:16 +0200
committerRoel Janssen <roel@gnu.org>2021-05-28 10:47:16 +0200
commit4ad3f818c9e2d200bf5c9cf0cf986b1a185d9d5b (patch)
tree92d1989e3a4cb5241d4b1eb82eaed440de142d92 /gnu/packages/python-xyz.scm
parentbd32bcca56ae4a27e754e43ace9bf28b0cae298e (diff)
downloadguix-4ad3f818c9e2d200bf5c9cf0cf986b1a185d9d5b.tar.gz
gnu: Add python-cachetools.
* gnu/packages/python-xyz.scm (python-cachetools): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c4f19b4c6f..d978942402 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -244,6 +244,24 @@
 from a docstring rather than the other way around.")
    (license license:mpl2.0)))
 
+(define-public python-cachetools
+  (package
+    (name "python-cachetools")
+    (version "4.2.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "cachetools" version))
+              (sha256
+               (base32
+                "1zqc098gk6y614lxwqd9z2gm8lldgvrpid133pnlm4m048gfvdb1"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/tkem/cachetools/")
+    (synopsis "Extensible memoizing collections and decorators")
+    (description "This module provides various memoizing collections and
+decorators, including variants of the Python standard library's
+@code{lru_cache} function decorator.")
+    (license license:expat)))
+
 (define-public python-colorful
   (package
     (name "python-colorful")