summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2021-02-01 09:52:31 +0100
committer宋文武 <iyzsong@member.fsf.org>2021-02-11 11:05:40 +0800
commit07143d9fe11151b884901186bace1b3ec65d9f40 (patch)
treeccd1dae5a0ab22a88e01901b90775857fc7d9cd1 /gnu/packages/python-xyz.scm
parentbdb3263c146f9e7ee5f982cb8f448af5b498b293 (diff)
downloadguix-07143d9fe11151b884901186bace1b3ec65d9f40.tar.gz
gnu: python-pkginfo: Enable tests.
* gnu/packages/python-xyz.scm (python-pkginfo)[arguments]: Don't disable tests.
Disable a failing test.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c6310e62b0..5e6f902a76 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17291,8 +17291,14 @@ design and layout.")
             "1d1xn1xmfvz0jr3pj8irdwnwby3r13g0r2gwklr1q5y68p5p16h2"))))
     (build-system python-build-system)
     (arguments
-     ;; The tests are broken upstream.
-     '(#:tests? #f))
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'patch-tests
+           (lambda _
+             (substitute* "pkginfo/tests/test_installed.py"
+               (("test_ctor_w_package_no_PKG_INFO")
+                "_test_ctor_w_package_no_PKG_INFO"))
+             #t)))))
     (home-page
       "https://code.launchpad.net/~tseaver/pkginfo/trunk")
     (synopsis