summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-12 22:56:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-12 22:56:42 +0200
commitdb3d74008a30fb200c46e13b31a6e79ef5439942 (patch)
treee00aae3548413f17e2be4208fe2b32668fd24901 /gnu/packages/python-xyz.scm
parent206815b796808874523dc3f928943c423b104f98 (diff)
downloadguix-db3d74008a30fb200c46e13b31a6e79ef5439942.tar.gz
gnu: python-seaborn: Simplify by using pyproject-build-system.
* gnu/packages/python-xyz.scm (python-seaborn)[arguments]: Remove.
[build-system]: Use pyproject-build-system.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 1 insertions, 22 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1710a303c1..1dc9c84f7f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11218,27 +11218,7 @@ SVG, EPS, PNG and terminal output.")
               (sha256
                (base32
                 "08vvnp4ps86857imxz2l5xi2vir5xdcdp3apq4badb4b5llifgw9"))))
-    (build-system python-build-system)
-    (arguments
-     (list #:modules '((guix build python-build-system)
-                       (guix build utils)
-                       (ice-9 match))
-           #:phases #~(modify-phases %standard-phases
-                        (replace 'build
-                          (lambda _
-                            (invoke "python" "-m" "build" "--wheel"
-                                    "--no-isolation" ".")))
-                        (replace 'install
-                          (lambda _
-                            (match (find-files "dist" "\\.whl$")
-                              ((wheel _ ...)
-                               (invoke "python" "-m" "pip" "install"
-                                       (string-append "--prefix=" #$output)
-                                       wheel)))))
-                        (replace 'check
-                          (lambda* (#:key tests? #:allow-other-keys)
-                            (when tests?
-                              (invoke "pytest" "-vv")))))))
+    (build-system pyproject-build-system)
     (propagated-inputs (list python-pandas python-matplotlib python-numpy
                              python-scipy))
     (native-inputs (list python-flit-core python-pypa-build python-pytest))
@@ -11251,7 +11231,6 @@ with the PyData stack, including support for numpy and pandas data structures
 and statistical routines from scipy and statsmodels.")
     (license license:bsd-3)))
 
-
 (define-public python-session-info
   (package
     (name "python-session-info")