summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-10 22:08:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-11 15:59:22 +0200
commite1c3adb27d0a92607b5341f7b4352e6b1e89e685 (patch)
tree7ab0dd8f7afa74c0326d06a42caf2020afeb6d19 /gnu/packages/python-xyz.scm
parent125f52c443c0257586421800d3a2e64f58759735 (diff)
downloadguix-e1c3adb27d0a92607b5341f7b4352e6b1e89e685.tar.gz
gnu: python-fsspec: Update to 2023.5.0.
* gnu/packages/python-xyz.scm (python-fsspec): Update to 2023.5.0.
[native-inputs]: Add python-pytest, python-pytest-mock, and python-numpy.
[propagated-inputs]: Add python-aiohttp, python-libarchive-c, python-requests,
and python-tqdm.
[arguments]: Add phase to embed the correct version string; disable tests that
need internet access.
[build-system]: Use pyproject-build-system.
[source]: Ftech sources with git to include tests.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 28 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1acef6bc00..dd6fdf92a1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24787,16 +24787,38 @@ append on old values.  Partd excels at shuffling operations.")
 (define-public python-fsspec
   (package
     (name "python-fsspec")
-    (version "2022.5.0")
+    (version "2023.5.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "fsspec" version))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/fsspec/filesystem_spec")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "1d43qiz8g395042a52yswz6j7q41gvrv3k53wvxn1rs4bk3mjm3s"))))
-    (build-system python-build-system)
-    (arguments '(#:tests? #f))          ; there are none
+         "0c0brw5s4330rj0yjcrqi56hanvaahn43854jai70qzqg1qvyl88"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-version
+            (lambda _
+              (substitute* "fsspec/__init__.py"
+                (("__version__ = .*")
+                 (string-append "__version__ = \"" #$version "\"")))
+              (substitute* "setup.py"
+                (("versioneer.get_version\\(\\)")
+                 (string-append "\"" #$version "\""))))))
+      #:test-flags
+      '(list
+        ;; requires internet access
+        "--ignore=fsspec/implementations/tests/test_dbfs.py")))
+    (propagated-inputs
+     (list python-aiohttp python-libarchive-c python-requests python-tqdm))
+    (native-inputs
+     (list python-pytest python-pytest-mock python-numpy))
     (home-page "https://github.com/intake/filesystem_spec")
     (synopsis "File-system specification")
     (description "The purpose of this package is to produce a template or