summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-30 14:27:57 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-10-30 14:32:17 +0100
commitadb396eae3524d9b82294aaf5cc87a615515b04d (patch)
treeff60d7d3b62f37a23ca11ae46ca8d5e4c24f41df /gnu/packages/python-xyz.scm
parent8cdfaef1185fa5dc5dbd21cc3592e77283b08752 (diff)
downloadguix-adb396eae3524d9b82294aaf5cc87a615515b04d.tar.gz
gnu: python2-numpy: Downgrade to 1.16.5.
Fixes <https://bugs.gnu.org/37989>.
Reported by Josh Holland <josh@inv.alid.pw>.

This is a follow-up to commit 8e5fbd5dda93e137ff527cabe25989b28ab9e1c0.

* gnu/packages/python-xyz.scm (python-numpy)[properties]: New field.
(python2-numpy): Downgrade to 1.16.5.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6392032d6e..061d9b9822 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3524,10 +3524,24 @@ with Python.  It contains among other things: a powerful N-dimensional array
 object, sophisticated (broadcasting) functions, tools for integrating C/C++
 and Fortran code, useful linear algebra, Fourier transform, and random number
 capabilities.")
+    (properties `((python2-variant . ,(delay python2-numpy))))
     (license license:bsd-3)))
 
+;; Numpy 1.16.x are the last versions that support Python 2.
 (define-public python2-numpy
-  (package-with-python2 python-numpy))
+  (let ((numpy (package-with-python2
+                (strip-python2-variant python-numpy))))
+    (package/inherit
+     numpy
+      (version "1.16.5")
+      (source (origin
+                (method url-fetch)
+                (uri (string-append
+                      "https://github.com/numpy/numpy/releases/download/v"
+                      version "/numpy-" version ".tar.gz"))
+                (sha256
+                 (base32
+                  "0lg1cycxzi4rvvrd5zxinpdz0ni792fpx6xjd75z1923zcac8qrb")))))))
 
 ;; NOTE: NumPy 1.8 is packaged only for Python 2 because it is of
 ;; interest only for legacy code going back to NumPy's predecessor