summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-16 14:31:03 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-16 15:48:07 +0200
commitf40c4b4ec9f1c16c56f7dc9ae511b2c6ee455356 (patch)
tree1b398f2eb2f52e51c99ba707f880834f528e6b3b /gnu/packages/python-xyz.scm
parent8aaa9b40aa1c62b1e704e0c1c9672301f2b93b91 (diff)
downloadguix-f40c4b4ec9f1c16c56f7dc9ae511b2c6ee455356.tar.gz
gnu: python-jupyter-console-minimal: Use 'modify-inputs'.
* gnu/packages/python-xyz.scm (python-jupyter-console-minimal)[propagated-inputs]:
Use 'modify-inputs'.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 199fcf5fb8..36171eb538 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14041,9 +14041,8 @@ Jupyter kernels such as IJulia and IRKernel.")
                  (assoc-ref outputs "out") "/bin"))))))))
     ;; Remove the python-ipython propagated input, to avoid the cycle
     (propagated-inputs
-     (alist-delete
-      "python-ipython"
-      (package-propagated-inputs python-jupyter-console)))))
+     (modify-inputs (package-propagated-inputs python-jupyter-console)
+       (delete "python-ipython")))))
 
 (define-public python-qtconsole
   (package