summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-22 14:19:43 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-07-22 14:31:28 +0200
commit2580c2f07f2882552ecfee5206dccf9ada15c7e1 (patch)
treef14728045261f9f00a621d2199b7f1ed8396c719 /gnu/packages/python.scm
parent4e52739c61e1b54f4988181c425bb9cbb3d92378 (diff)
downloadguix-2580c2f07f2882552ecfee5206dccf9ada15c7e1.tar.gz
gnu: python-pyopenssl: Update to 17.2.0.
* gnu/packages/patches/python-pyopenssl-17.1.0-test-overflow.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/python.scm (python-pyopenssl, python2-pyopenssl): Update to 17.2.0.
[native-inputs]: Add PYTHON-FLAKY.
[source](patches): Remove.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 619dc07ee0..ce2864e1c6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7709,16 +7709,14 @@ message digests and key derivation functions.")
 (define-public python-pyopenssl
   (package
     (name "python-pyopenssl")
-    (version "17.1.0")
+    (version "17.2.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pyOpenSSL" version))
-       (patches
-        (search-patches "python-pyopenssl-17.1.0-test-overflow.patch"))
        (sha256
         (base32
-         "0qwmqhfsq84ydir9dz273ypmlcvs7v71m1jns0sd4k0h6lfsa82s"))))
+         "0d283g4zi0hr9papd24mjl70mi15gyzq6fx618rizi87dgipqqax"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -7742,7 +7740,8 @@ message digests and key derivation functions.")
     (inputs
      `(("openssl" ,openssl)))
     (native-inputs
-     `(("python-pretend" ,python-pretend)
+     `(("python-flaky" ,python-flaky)
+       ("python-pretend" ,python-pretend)
        ("python-pytest" ,python-pytest-3.0)))
     (home-page "https://github.com/pyca/pyopenssl")
     (synopsis "Python wrapper module around the OpenSSL library")