summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-25 23:33:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-25 23:35:39 +0300
commita800018e03a5dab0c8577b89c820760b0b44ed8e (patch)
tree7a621a4556b6186b18936e817db253babd1ec511 /gnu/packages/python.scm
parent783fb0a3a29cfc7283729bfb6ea0dce9b9e0b293 (diff)
downloadguix-a800018e03a5dab0c8577b89c820760b0b44ed8e.tar.gz
gnu: python2-pysnptools: Update to 0.3.9.
* gnu/packages/python.scm (python2-pysnptools): Update to 0.3.9.
[propagated-inputs]: Add python2-pytz. Move python2-pandas ...
[inputs]: ... to here. Add python2-dateutil-2, python2-six.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2a6bac79fc..3266613b97 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3419,22 +3419,26 @@ toolkits.")
 (define-public python2-pysnptools
   (package
     (name "python2-pysnptools")
-    (version "0.3.5")
+    (version "0.3.9")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pysnptools" version ".zip"))
        (sha256
         (base32
-         "15f4j4w5q603i7mlphb5r6mb1mn33pqg81595fpjp158140yqx7b"))))
+         "1wybggjzz8zw7aav4pjsg2h22xp17a1lghrprza1pxwlm7wf96y2"))))
     (build-system python-build-system)
     (arguments
      `(#:python ,python-2)) ; only Python 2.7 is supported
     (propagated-inputs
      `(("python2-numpy" ,python2-numpy)
        ("python2-scipy" ,python2-scipy)
-       ("python2-pandas" ,python2-pandas)
+       ("python2-pytz" ,python2-pytz)
        ("python2-cython" ,python2-cython)))
+    (inputs
+     `(("python2-dateutil-2" ,python2-dateutil-2)
+       ("python2-pandas" ,python2-pandas)
+       ("python2-six" ,python2-six)))
     (native-inputs
      `(("unzip" ,unzip)
        ("python2-setuptools" ,python2-setuptools)))