summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-16 21:48:40 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:43 +0100
commit2887700e4d6e9d43df97d9b11d9aba935951a3e8 (patch)
tree7e6ec0bb8d5e69176e8ba27720559f3bf0f91b45 /gnu/packages/python.scm
parentfe94cf0cdd8f94599fa79f163257a1feea4946e8 (diff)
downloadguix-2887700e4d6e9d43df97d9b11d9aba935951a3e8.tar.gz
gnu: python-pathpy: Build documentation.
* gnu/packages/python.scm (python-pathpy, python2-pathpy)
  [output] Add output "doc".
  [native-inputs]: Add python-sphinx and python-rst.linker
  [build-doc], [install-doc]: New build phases.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a261400383..62c5ecae6e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4398,13 +4398,33 @@ them as the version argument or in a SCM managed file.")
                            "path.py/path.py-" version ".tar.gz"))
        (sha256
         (base32 "1p8s1l2vfkqhqxdhqlj0g1jjw4f1as2frr35sjcpjjpd5a89y41f"))))
+    (outputs '("out" "doc"))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-appdirs" ,python-appdirs)))
     (native-inputs
      `(("python-setuptools-scm" ,python-setuptools-scm)
+       ("python-sphinx" ,python-sphinx)
+       ("python-rst.linker" ,python-rst.linker)
        ("python-pytest" ,python-pytest)
        ("python-pytest-runner" ,python-pytest-runner)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'build 'build-doc
+           (lambda _
+             (setenv "LANG" "en_US.UTF-8")
+             (zero? (system* "python" "setup.py" "build_sphinx"))))
+         (add-after 'install 'install-doc
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((data (string-append (assoc-ref outputs "doc") "/share"))
+                    (doc (string-append data "/doc/" ,name "-" ,version))
+                    (html (string-append doc "/html")))
+               (mkdir-p html)
+               (for-each (lambda (file)
+                           (copy-file file (string-append doc "/" file)))
+                         '("README.rst" "CHANGES.rst"))
+               (copy-recursively "build/sphinx/html" html)))))))
     (home-page "http://github.com/jaraco/path.py")
     (synopsis "Python module wrapper for built-in os.path")
     (description