summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-12-14 09:42:40 +0100
committerLudovic Courtès <ludo@gnu.org>2020-12-14 10:34:31 +0100
commit5fe87ef51c0b6c41ad8f53579f0fd515f0ab059e (patch)
treede59d443927d91df31473eb3f5224affbcad9998 /gnu/packages/python.scm
parent9f3cb56038392e76c001d3da4176d5363186871a (diff)
downloadguix-5fe87ef51c0b6c41ad8f53579f0fd515f0ab059e.tar.gz
gnu: Add python-3.9.
* gnu/packages/python.scm (python-3.9): New variable.
* gnu/packages/patches/python-3.9-fix-tests.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 43704bccae..fa9bf10e07 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -520,6 +520,31 @@ data types.")
                                         (version-major+minor version)
                                         "/site-packages"))))))))
 
+(define-public python-3.9
+  (package (inherit python-3.8)
+    (name "python-next")
+    (version "3.9.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://www.python.org/ftp/python/"
+                                  version "/Python-" version ".tar.xz"))
+              (patches (search-patches
+                        "python-3.9-fix-tests.patch"
+                        "python-3-deterministic-build-info.patch"
+                        "python-3-search-paths.patch"))
+              (sha256
+               (base32
+                "1zq3k4ymify5ig739zyvx9s2ainvchxb1zpy139z74krr653y74r"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  ;; Delete the bundled copy of libexpat.
+                  (delete-file-recursively "Modules/expat")
+                  (substitute* "Modules/Setup"
+                    ;; Link Expat instead of embedding the bundled one.
+                    (("^#pyexpat.*") "pyexpat pyexpat.c -lexpat\n"))
+                  #t))))))
+
 ;; Current 3.x version.
 (define-public python-3 python-3.8)