summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-05-05 17:12:55 +0200
committerLudovic Courtès <ludo@gnu.org>2014-05-05 17:12:55 +0200
commit6f194a1e7700997d3c61fa91c58c36da0f96e5c2 (patch)
tree9989a6b6f28381a8b05059a71bfc7783d3d054f3 /gnu/packages/python.scm
parent515eba4543f658799b1e11d187fa599d0a9a0dce (diff)
downloadguix-6f194a1e7700997d3c61fa91c58c36da0f96e5c2.tar.gz
gnu: pybugz: Add fixlet patches.
* gnu/packages/python.scm (python2-pybugz)[source]: Add 'patches'
  field.
* gnu/packages/patches/pybugz-encode-error.patch,
  gnu/packages/patches/pybugz-stty.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 372f763ee5..d3d4f390ff 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -578,7 +578,10 @@ commands.")
                     version ".tar.gz"))
               (sha256
                (base32
-                "17ni00p08gp5lkxlrrcnvi3x09fmajnlbz4da03qcgl9q21ym4jd"))))
+                "17ni00p08gp5lkxlrrcnvi3x09fmajnlbz4da03qcgl9q21ym4jd"))
+              (patches (map search-patch
+                            (list "pybugz-stty.patch"
+                                  "pybugz-encode-error.patch")))))
     (build-system python-build-system)
     (arguments
      `(#:python ,python-2                         ; SyntaxError with Python 3