summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:17 +0200
commit9769867272b6120de5ff846e48211a51838aaa96 (patch)
tree3202f7d2050519897e18977b0bbf138af84e3c7f /gnu/packages/python.scm
parent494a34410ebf94f8461f435d15c3baadf14c2ec6 (diff)
downloadguix-9769867272b6120de5ff846e48211a51838aaa96.tar.gz
gnu: micropython: Use G-expressions.
* gnu/packages/python.scm (micropython)[arguments]:
Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm46
1 files changed, 24 insertions, 22 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4676409eec..1727024bfe 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -692,28 +692,30 @@ To function properly, this package should not be installed together with the
                       '("libffi" "lwip" "stm32lib" "nrfx")))))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'build 'build-mpy-cross
-           (lambda* (#:key make-flags #:allow-other-keys)
-             (with-directory-excursion "mpy-cross"
-               (apply invoke "make" make-flags))))
-         (add-after 'build-mpy-cross 'prepare-build
-           (lambda _
-             (chdir "ports/unix")
-             ;; see: https://github.com/micropython/micropython/pull/4246
-             (substitute* "Makefile"
-               (("-Os") "-Os -ffp-contract=off"))))
-         (replace 'install-license-files
-           ;; We don't build in the root directory so the file isn't found.
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out  (assoc-ref outputs "out"))
-                    (dest (string-append out "/share/doc/" ,name "-" ,version "/")))
-               (install-file "../../LICENSE" dest))))
-         (delete 'configure)) ; no configure
-       #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
-                          "V=1")
-       #:test-target "test"))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'build 'build-mpy-cross
+                 (lambda* (#:key make-flags #:allow-other-keys)
+                   (with-directory-excursion "mpy-cross"
+                     (apply invoke "make" make-flags))))
+               (add-after 'build-mpy-cross 'prepare-build
+                 (lambda _
+                   (chdir "ports/unix")
+                   ;; see: https://github.com/micropython/micropython/pull/4246
+                   (substitute* "Makefile"
+                     (("-Os") "-Os -ffp-contract=off"))))
+               (replace 'install-license-files
+                 ;; We don't build in the root directory so the file isn't found.
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let* ((out  (assoc-ref outputs "out"))
+                          (doc (string-append out "/share/doc/"
+                                              #$name "-" #$version "/")))
+                     (install-file "../../LICENSE" doc))))
+               (delete 'configure))       ; no configure
+           #:make-flags
+           #~(list (string-append "PREFIX=" #$output)
+                   "V=1")
+           #:test-target "test"))
     (native-inputs (list pkg-config python-wrapper))
     (inputs
      (list libffi))