summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-08 16:57:37 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-08 16:57:37 +0200
commit11bb85a10d4a84dab7fdfaaaf7012b743ce7a09f (patch)
tree27f51d1c065139ed94d00b23709205744af82918 /gnu/packages/python.scm
parentb191f88ee34576a6908b9b5e94cb7664e88c7e79 (diff)
downloadguix-11bb85a10d4a84dab7fdfaaaf7012b743ce7a09f.tar.gz
guix: python: Add package-with-python2, a procedure rewriting a package
  to compile with Python 2 instead of the default Python 3.

* guix/build-system/python.scm (default-python2, package-with-explicit-python,
    package-with-python2): New procedures.
* guix/build-system/python.scm (python2-pytz, python2-babel): Use
    package-with-python2.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ce89281e26..3ff4da2149 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -28,6 +28,7 @@
   #:use-module (gnu packages patchelf)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
   #:use-module (guix build-system trivial))
@@ -215,9 +216,7 @@ using Python 2.4 or higher and provides access to the Olson timezone database.")
     (license x11)))
 
 (define-public python2-pytz
-  (package (inherit python-pytz)
-    (name "python2-pytz")
-    (arguments (append (package-arguments python-pytz) `(#:python ,python-2)))))
+  (package-with-python2 python-pytz))
 
 (define-public python-babel
   (package
@@ -247,8 +246,4 @@ etc. ")
     (license bsd-3)))
 
 (define-public python2-babel
-  (package (inherit python-babel)
-    (name "python2-babel")
-    (inputs
-     `(("python2-pytz" ,python2-pytz)))
-    (arguments (append (package-arguments python-babel) `(#:python ,python-2)))))
+  (package-with-python2 python-babel))