summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-12-01 22:03:48 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-12-02 18:21:14 +0100
commit18b3151613e90eb7b4e0d174069ccc9fbe99b721 (patch)
tree040995dc8c99338c0a4fa4aa2b04403cdd34b6a0 /gnu/packages/python.scm
parent5d26e542ee624e764f9f273e45ea6f0fc718ecf7 (diff)
downloadguix-18b3151613e90eb7b4e0d174069ccc9fbe99b721.tar.gz
gnu: python-matplotlib: Adjust path to figures in 'info' file.
* gnu/packages/python.scm (python-matplotlib): Do it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 513910e5f6..45222e9984 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3276,13 +3276,23 @@ backend = TkAgg~%"
                ;; The doc recommends to run the 'html' target twice.
                (system* "python" "make.py" "html")
                (system* "python" "make.py" "html")
+               (copy-recursively "build/html" html)
                (system* "python" "make.py" "latex")
                (system* "python" "make.py" "texinfo")
+               (symlink (string-append html "/_images")
+                        (string-append info "/matplotlib-figures"))
+               (with-directory-excursion "build/texinfo"
+                 (substitute* "matplotlib.texi"
+                   (("@image\\{([^,]*)" all file)
+                    (string-append "@image{matplotlib-figures/" file)))
+                 (symlink (string-append html "/_images")
+                          "./matplotlib-figures")
+                 (system* "makeinfo" "--no-split"
+                          "-o" "matplotlib.info" "matplotlib.texi"))
                (copy-file "build/texinfo/matplotlib.info"
                           (string-append info "/matplotlib.info"))
                (copy-file "build/latex/Matplotlib.pdf"
-                          (string-append doc "/Matplotlib.pdf"))
-               (copy-recursively "build/html" html))))
+                          (string-append doc "/Matplotlib.pdf")))))
         %standard-phases))))
     (home-page "http://matplotlib.org")
     (synopsis "2D plotting library for Python")