summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-10 16:20:49 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-12 09:03:27 +0100
commit2cfcab3aef1efaab0e06540cd175e8c9912ac2a8 (patch)
treeaca86a18804cf38a16fb48b2e7523404e19c0c55 /gnu/packages/python.scm
parent679c979f25e27ea559cf26e806baee4d69ece7bd (diff)
downloadguix-2cfcab3aef1efaab0e06540cd175e8c9912ac2a8.tar.gz
gnu: Add python-vine.
This is needed to update python-amqp to 2.3.2.

* gnu/packages/python.scm (python-vine): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e4ef234d8f..16847d8647 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2317,6 +2317,30 @@ object.")
 (define-public python2-pyyaml
   (package-with-python2 python-pyyaml))
 
+(define-public python-vine
+  (package
+    (name "python-vine")
+    (version "1.1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "vine" version))
+       (sha256
+        (base32
+         "0wkskb2hb494v9gixqnf4bl972p4ibcmxdykzpwjlfa5picns4aj"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-case" ,python-case)))
+    (home-page "https://github.com/celery/vine")
+    (synopsis "Promises for Python")
+    (description
+     "@code{vine} provides a special implementation of promises in that it can
+be used both for \"promise of a value\" and lazy evaluation.  The biggest
+upside for this is that everything in a promise can also be a promise,
+e.g. filters, callbacks and errbacks can all be promises.")
+    (license license:bsd-3)))
+
 (define-public python-virtualenv
   (package
     (name "python-virtualenv")