summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-19 22:10:12 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-19 23:42:57 +0100
commit5927a843b4a91416b5be9e65c69616447f82e162 (patch)
tree5415d0ae0a93b6890881336ea5010401aedd6754 /gnu/packages/python.scm
parent4ed06287376bc1632c6bca4a395795bc8cc1b874 (diff)
downloadguix-5927a843b4a91416b5be9e65c69616447f82e162.tar.gz
gnu: python-minimal@2: Add dependencies on libffi and zlib.
* gnu/packages/python.scm (python2-minimal)[inputs]: Add LIBFFI and ZLIB.
[arguments]: Remove.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index be452f0627..00598776ab 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -359,11 +359,12 @@ data types.")
   (package (inherit python-2)
     (name "python-minimal")
     (outputs '("out"))
-    (arguments
-     (substitute-keyword-arguments (package-arguments python-2)
-       ((#:configure-flags cf)
-        `(append ,cf '("--without-system-ffi")))))
-    (inputs '())))                          ;none of the optional dependencies
+
+    ;; Keep zlib, which is used by 'pip' (via the 'zipimport' module), which
+    ;; is invoked upon 'make install'.  'pip' also expects 'ctypes' and thus
+    ;; libffi.
+    (inputs `(("libffi" ,libffi)
+              ("zlib" ,zlib)))))
 
 (define-public python-minimal
   (package (inherit python)