summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-03-26 12:23:32 +0300
committerLeo Famulari <leo@famulari.name>2017-03-28 15:59:18 -0400
commit7f71e2579aca806be2fd30211fddeea69cafe31e (patch)
tree2334dfc869cfd414402aa39f9565c670becb1a21 /gnu/packages/python.scm
parenta652eb9331037e0d932ca05af37a40fc19e6919e (diff)
downloadguix-7f71e2579aca806be2fd30211fddeea69cafe31e.tar.gz
gnu: Add python-pytest@3.0.7
* gnu/packages/python.scm (python-pytest-3.0.7): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c3e4a3795f..e804da9025 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1843,6 +1843,24 @@ and many external plugins.")
                                line)))
              #t)))))))
 
+;; This package is used by Sphinx version 1.5.2 and up
+(define-public python-pytest-3.0.7
+  (package
+    (inherit python-pytest-2.9.2)
+    (name "python-pytest")
+    (version "3.0.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest" version))
+       (sha256
+        (base32
+         "1asc4b2nd2a4f0g3r12y97rslq5wliji7b73wwkvdrm5s7mrc1mp"))))
+    (native-inputs
+     `(("python-nose" ,python-nose)
+       ("python-mock" ,python-mock)
+       ("python-hypothesis" ,python-hypothesis)))))
+
 (define-public python-pytest-cov
   (package
     (name "python-pytest-cov")