summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-10 16:21:13 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-12 09:03:27 +0100
commit9253c429738d5be26edbf4febb39aa85aa88ec90 (patch)
tree16fcbd6efba42a2d9605617da7f1e4aa925d8b0d /gnu/packages/python.scm
parent2cfcab3aef1efaab0e06540cd175e8c9912ac2a8 (diff)
downloadguix-9253c429738d5be26edbf4febb39aa85aa88ec90.tar.gz
gnu: Add python-pyro4.
This is needed to update python-kombu to 4.2.2

* gnu/packages/python.scm (python-pyro4): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 16847d8647..25c84199ec 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13332,6 +13332,28 @@ such as figshare or Zenodo.")
 (define-public python2-semver
   (package-with-python2 python-semver))
 
+(define-public python-pyro4
+  (package
+    (name "python-pyro4")
+    (version "4.74")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Pyro4" version))
+       (sha256
+        (base32
+         "0pzp7c6q3vvkxq0wy9lr6wd5wky40sajz69g697i5rb2q497pvc9"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-serpent" ,python-serpent)))
+    (home-page "https://pyro4.readthedocs.io")
+    (synopsis "Distributed object middleware for Python")
+    (description
+     "Pyro enables you to build applications in which objects can talk to each
+other over the network.  You can just use normal Python method calls to call
+objects on other machines, also known as remote procedure calls (RPC).")
+    (license license:expat)))
+
 (define-public python2-pyro
   (package
     (name "python2-pyro")