summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-06-21 10:36:07 +0200
committerRoel Janssen <roel@gnu.org>2017-06-21 10:36:07 +0200
commitfa3f5f472ccceafa537fc66fc896b941a887efe5 (patch)
tree6834fa67a0f8ef185ebb46900dc92e85f81d57ee /gnu/packages/python.scm
parenta48a20fb98b3f69a2640be43cd9e01a1ff90601f (diff)
downloadguix-fa3f5f472ccceafa537fc66fc896b941a887efe5.tar.gz
gnu: Add python-regex.
* gnu/packages/python.scm (python-regex, python2-regex): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 775cab6948..251c2b267a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -40,6 +40,7 @@
 ;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
+;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -15423,3 +15424,24 @@ window memory map manager.")
 
 (define-public python2-smmap2
   (package-with-python2 python-smmap2))
+
+(define-public python-regex
+  (package
+    (name "python-regex")
+    (version "2017.06.07")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "regex" version))
+              (sha256
+               (base32
+                "06r6b7yigikbj3a72whl85r2b64pj1r0ypmw9yalmkm0wnxq8mz4"))))
+    (build-system python-build-system)
+    (home-page "https://bitbucket.org/mrabarnett/mrab-regex")
+    (synopsis "Alternative regular expression module")
+    (description "This regular expression implementation is backwards-
+compatible with the standard @code{re} module, but offers additional
+functionality like full case-folding for case-insensitive matches in Unicode.")
+    (license license:psfl)))
+
+(define-public python2-regex
+  (package-with-python2 python-regex))