summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-14 18:34:48 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-14 18:36:52 +0100
commit30e0229a1713e77dc0397dfb4ee6af4ac6a00443 (patch)
treee20e2c564b0156154425fba5a02eee892964a108 /gnu/packages/python.scm
parentbd100c7112b1717881ff6efcaa514be5cfeb5349 (diff)
downloadguix-30e0229a1713e77dc0397dfb4ee6af4ac6a00443.tar.gz
gnu: python-pyopenssl: Disable tests.
* gnu/packages/python.scm (python-pyopenssl, python2-pyopenssl)[arguments]:
Set #:tests? #f.
[native-inputs]: Add python-pytest.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cd6ed1c240..ebe0194aa4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6585,11 +6585,16 @@ message digests and key derivation functions.")
         (base32
          "0vji4yrfshs15xpczbhzhasnjrwcarsqg87n98ixnyafnyxs6ybp"))))
     (build-system python-build-system)
+    (arguments
+     ;; FIXME: Some tests fail with "NameError: name 'long' is not defined".
+     '(#:tests? #f))
     (propagated-inputs
      `(("python-cryptography" ,python-cryptography)
        ("python-six" ,python-six)))
     (inputs
      `(("openssl" ,openssl)))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
     (home-page "https://github.com/pyca/pyopenssl")
     (synopsis "Python wrapper module around the OpenSSL library")
     (description