summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:17 +0200
commit847aa3942b5edea04d56dfb75ad1d88a3e9bb256 (patch)
tree9dec4d7743c6e6bc03c55be24112f108251e1525 /gnu/packages/python.scm
parent9769867272b6120de5ff846e48211a51838aaa96 (diff)
downloadguix-847aa3942b5edea04d56dfb75ad1d88a3e9bb256.tar.gz
gnu: micropython: Don't override 'install-license-files.
* gnu/packages/python.scm (micropython)[arguments]: Prefix a new
'chdir-back phase instead of overriding 'install-license-files.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1727024bfe..ad475d8acc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -704,13 +704,10 @@ To function properly, this package should not be installed together with the
                    ;; see: https://github.com/micropython/micropython/pull/4246
                    (substitute* "Makefile"
                      (("-Os") "-Os -ffp-contract=off"))))
-               (replace 'install-license-files
+               (add-before 'install-license-files 'chdir-back
                  ;; We don't build in the root directory so the file isn't found.
-                 (lambda* (#:key outputs #:allow-other-keys)
-                   (let* ((out  (assoc-ref outputs "out"))
-                          (doc (string-append out "/share/doc/"
-                                              #$name "-" #$version "/")))
-                     (install-file "../../LICENSE" doc))))
+                 (lambda _
+                   (chdir "../..")))
                (delete 'configure))       ; no configure
            #:make-flags
            #~(list (string-append "PREFIX=" #$output)