summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-01-14 18:04:17 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-01-18 18:05:53 +0100
commitda6ce3f1b864077002d912a22a40f31c57bc2d43 (patch)
tree05522f139f979995fa33d353ee2cf11c53885175 /gnu/packages/python.scm
parent3e6ccb53559c8a0cb9ea010ec747df4e5972fcd3 (diff)
downloadguix-da6ce3f1b864077002d912a22a40f31c57bc2d43.tar.gz
gnu: python-scipy: Update to 0.15.0.
* gnu/packages/python.scm (python-scipy): Update to 0.15.0.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm20
1 files changed, 4 insertions, 16 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a1be20c21f..2f518d940d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
+;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2271,30 +2271,18 @@ toolkits.")
          ,@(alist-delete "python-numpydoc" 
                          (package-inputs matplotlib)))))))
 
-;; Scipy 0.14.0 with Numpy 0.19.X fails several tests.  This is known and
-;; planned to be fixed in 0.14.1.  It is claimed that the failures can safely
-;; be ignored:
-;; http://mail.scipy.org/pipermail/scipy-dev/2014-September/020043.html
-;; https://github.com/scipy/scipy/issues/3853 
-;;
-;; The main test suite procedure prints the summary message:
-;;
-;; Ran 16412 tests in 245.033s
-;; FAILED (KNOWNFAIL=277, SKIP=921, errors=327, failures=42)
-;; 
-;; However, it still does return normally.
 (define-public python-scipy
   (package
     (name "python-scipy")
-    (version "0.14.0")
+    (version "0.15.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://sourceforge/scipy"
-                           "/scipy-" version ".tar.gz"))
+                           "/scipy-" version ".tar.xz"))
        (sha256
         (base32
-         "053bmz4qmnk4dmxvspfak8r10rpmy6mzwfzgy33z338ppzka6hab"))))
+         "0fsqi05s035d7p6s8h3h2pvk1axias16chy17rw9l1bxvrfhmncf"))))
     (build-system python-build-system)
     (inputs
      `(("python-numpy" ,python-numpy)