summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-10-21 22:56:09 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-25 22:25:19 -0700
commit2a81537f2fe20f1d65222606c97a62ec84a557b8 (patch)
treeee20663b00c6b2018e6aea9aa48522316900cbfb /gnu/packages/python.scm
parent92eb9a35355df03803f4dd087d0c2a9e57bd718e (diff)
downloadguix-2a81537f2fe20f1d65222606c97a62ec84a557b8.tar.gz
gnu: Add python-capturer.
* gnu/packages/python.scm (python-capturer, python2-capturer): New
variables.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cddbd8c208..2b2457f978 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1129,6 +1129,34 @@ helpers.")
 (define-public python2-humanfriendly
   (package-with-python2 python-humanfriendly))
 
+(define-public python-capturer
+  (package
+    (name "python-capturer")
+    (version "2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "capturer" version))
+       (sha256
+        (base32
+         "05d6ji4j8ipiq0br7bwam38qc6hd9l1djmfxlzrxx19ziyjl4089"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))
+    (propagated-inputs
+     `(("python-humanfriendly" ,python-humanfriendly)))
+    (home-page "https://capturer.readthedocs.io")
+    (synopsis "Capture stdout and stderr streams of the current process")
+    (description
+     "The capturer package makes it easy to capture the stdout and stderr
+streams of the current process and subprocesses.  Output can be relayed
+to the terminal in real time but is also available to the Python program
+for additional processing.")
+    (license license:expat)))
+
+(define-public python2-capturer
+  (package-with-python2 python-capturer))
+
 (define-public python-eventlet
   (package
     (name "python-eventlet")