summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-10-27 20:21:26 -0400
committerMark H Weaver <mhw@netris.org>2016-10-27 20:21:26 -0400
commit3d82676919b952d0a7e205fa5da6320b1cf21e21 (patch)
tree02586fee407b667fc9e082f98ad70356eedd7864 /gnu/packages/python.scm
parentf9a65318ddc34a84fea128b756d23ad619f519dc (diff)
parent7500e42b3e51fa9ba5fb2ba552f168081b7f044a (diff)
downloadguix-3d82676919b952d0a7e205fa5da6320b1cf21e21.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 73cabe8228..9b25b3ff62 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7773,14 +7773,14 @@ concurrent.futures package from Python 3.2")
 (define-public python-urllib3
   (package
     (name "python-urllib3")
-    (version "1.13.1")
+    (version "1.18.1")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "urllib3" version))
         (sha256
          (base32
-          "10rrbr6c6k7j5dvfsyj4b2gsgxg9gggnn708qixf6ll57xqivfkf"))))
+          "1wb8aqnq53vzh2amrv8kc66f3h6fx217y0q62y6n30a64p2yqmam"))))
     (build-system python-build-system)
     (arguments `(#:tests? #f))
     (native-inputs
@@ -7795,7 +7795,7 @@ concurrent.futures package from Python 3.2")
        ("python-ndg-httpsclient" ,python-ndg-httpsclient)
        ("python-pyasn1" ,python-pyasn1)
        ("python-pyopenssl" ,python-pyopenssl)))
-    (home-page "http://urllib3.readthedocs.org/")
+    (home-page "https://urllib3.readthedocs.org/")
     (synopsis "HTTP library with thread-safe connection pooling")
     (description
      "Urllib3 supports features left out of urllib and urllib2 libraries.  It
@@ -8984,6 +8984,9 @@ anymore.")
                (base32
                 "0p050msg5c8d0kadv702jnfshaxrb0il765cpkgnhn6mq5hakcyy"))))
     (build-system python-build-system)
+    ;; We only need the the Python 2 variant, since for Python 3 our minimum
+    ;; version is 3.4 which already includes this package as part of the
+    ;; standard library.
     (arguments
      `(#:python ,python-2))
     (native-inputs