summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-15 09:32:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-15 11:57:15 +0300
commita1add5b7fb0fc56aa340fa97170ba1b56784f8f6 (patch)
treeee65080ec74af5be2a442def2f7e9de77639463c /gnu/packages/python.scm
parentdd46c16b121b8cb56c415c5b26e94d7bed219271 (diff)
downloadguix-a1add5b7fb0fc56aa340fa97170ba1b56784f8f6.tar.gz
gnu: python-cffi: Disable test that fails on aarch64.
* gnu/packages/python.cm (python-cffi)[arguments]: Disable test that
is known to fail on aarch64.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1b1be11c68..69802355ec 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5180,6 +5180,13 @@ a front-end for C compilers or analysis tools.")
              (substitute* "testing/cffi0/test_ownlib.py"
                (("'cc testownlib") "'gcc testownlib"))
              (zero? (system* "py.test" "-v" "c/" "testing/"))))
+         (add-before 'check 'disable-failing-test
+           ;; This is assumed to be a libffi issue:
+           ;; https://bitbucket.org/cffi/cffi/issues/312/tests-failed-with-armv8
+           (lambda _
+             (substitute* "testing/cffi0/test_ownlib.py"
+               (("ret.left") "ownlib.left"))
+             #t))
          (add-after 'install 'install-doc
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((data (string-append (assoc-ref outputs "doc") "/share"))