summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-14 16:38:31 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-19 00:16:51 +0200
commit3e6218b2dde7b1b6b932b0d2dc9c1ead408a93f5 (patch)
tree834677f1c3cf8b111af97ad391bf1adf42a4ee44 /gnu/packages/python.scm
parent8f6536128652838fa60e196270b0cc9deb7e6763 (diff)
downloadguix-3e6218b2dde7b1b6b932b0d2dc9c1ead408a93f5.tar.gz
gnu: Fix pytest dependency cycle.
* gnu/packages/python.scm (python-traceback2,
python-linecache2)[native-inputs]: Use PYTHON-PBR-MINIMAL instead of PYTHON-PBR.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e13b9552cc..35ea8c4ca1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -16670,7 +16670,7 @@ their files and supports any packaging format (including wheels).")
      `(;; The tests depend on unittest2, and our version is a bit too old.
        #:tests? #f))
     (native-inputs
-     `(("python-pbr" ,python-pbr)))
+     `(("python-pbr" ,python-pbr-minimal)))
     (home-page
       "https://github.com/testing-cabal/linecache2")
     (synopsis "Backports of the linecache module")
@@ -16699,7 +16699,7 @@ lines are read from a single file.")
      `(;; python-traceback2 and python-unittest2 depend on one another.
        #:tests? #f))
     (native-inputs
-     `(("python-pbr" ,python-pbr)))
+     `(("python-pbr" ,python-pbr-minimal)))
     (propagated-inputs
       `(("python-linecache2" ,python-linecache2)))
     (home-page