summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-07 15:18:04 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-07 15:34:09 +0100
commit5861f9c9d685c0f7921c7cf118e02c9d4b094485 (patch)
tree8a08d8125d02ef99589377c56ccb0b4da961e054 /gnu/packages/python.scm
parentf7bd4f23723cf8985c4859945020c5e6cc772637 (diff)
downloadguix-5861f9c9d685c0f7921c7cf118e02c9d4b094485.tar.gz
gnu: python-radon: Update to 2.2.0.
* gnu/packages/python.scm (python-radon): Update to 2.2.0.
[arguments]: Replace CHECK-PHASE with custom test command.
[propagated-inputs]: Replace PYTHON-MANDO-0.3.1 with PYTHON-MANDO.
[native-inputs]: Remove PYTHON-FLAKE8, PYTHON-TOX and PYTHON-PARAMUNITTEST.
Add PYTHON-PYTEST-MOCK.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c7308d1326..e5fe4f6f75 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11238,24 +11238,27 @@ for more filetypes can be easily added by creating plugins for them.")
 (define-public python-radon
   (package
     (name "python-radon")
-    (version "1.5.0")
+    (version "2.2.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "radon" version))
        (sha256
         (base32
-         "1h6jv36am0i827182a04ki6291lyx4kp957xfr5njgprj4nd0qsl"))))
+         "07gq5hq4nrffxnlnksws9hrx7fd001gam63j62i82gyfr23gvdym"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      (invoke "python" "radon/tests/run.py"))))))
     (propagated-inputs
      `(("python-colorama" ,python-colorama)
        ("python-flake8-polyfill" ,python-flake8-polyfill)
-       ("python-mando" ,python-mando-0.3.1)))
+       ("python-mando" ,python-mando)))
     (native-inputs
-     `(("python-flake8" ,python-flake8)
-       ("python-tox" ,python-tox)
-       ("python-pytest" ,python-pytest)
-       ("python-paramunittest" ,python-paramunittest)))
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-mock" ,python-pytest-mock)))
     (home-page "https://radon.readthedocs.org/")
     (synopsis "Code Metrics in Python")
     (description "Radon is a Python tool which computes various code metrics.