summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-31 03:59:55 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-19 00:16:51 +0200
commita6c6a59faf648f4fe23f40d362aff14d8bcd98af (patch)
tree24c2c3ae36ce2aa0edce93d09ef4f93ed2a9f1a4 /gnu/packages/python.scm
parent3e6218b2dde7b1b6b932b0d2dc9c1ead408a93f5 (diff)
downloadguix-a6c6a59faf648f4fe23f40d362aff14d8bcd98af.tar.gz
gnu: Add python2-enum.
* gnu/packages/python.scm (python2-enum): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 35ea8c4ca1..13943df45f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1573,6 +1573,28 @@ bug tracker.")
     (home-page "http://www.liquidx.net/pybugz/")
     (license license:gpl2)))
 
+(define-public python2-enum
+  (package
+    (name "python2-enum")
+    (version "0.4.6")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "enum" version))
+              (sha256
+               (base32
+                "13lk3yrwj42vl30kw3c194f739nrfrdg64s6i0v2p636n4k8brsl"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2))
+    (home-page "http://pypi.python.org/pypi/enum/")
+    (synopsis "Robust enumerated type support in Python")
+    (description
+     "This provides a module for robust enumerations in Python.  It has
+been superseded by the Python standard library and is provided only for
+compatibility.")
+    ;; Choice of either license.
+    (license (list license:gpl3+ license:psfl))))
+
 (define-public python-enum34
   (package
     (name "python-enum34")