summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-07 21:22:21 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-07 22:10:16 +0100
commit027250f1a65f5500a68687a32e444f424bda7fda (patch)
tree0ff3f15fae7ddca6c36574a08d1c6cc251c103da /gnu/packages/python.scm
parent0293b353bdde6b9593138a48fc78a500423fda0d (diff)
downloadguix-027250f1a65f5500a68687a32e444f424bda7fda.tar.gz
gnu: python2: Incorporate grafted changes.
* gnu/packages/python.scm (python-2.7)[source](patches): Add
python2-CVE-2018-14647.patch and python2-CVE-2018-1000802.patch.
[replacement]: Remove field.
(python-2/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 69b8b3fd4d..87b80f9c40 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -95,7 +95,6 @@
   (package
     (name "python2")
     (version "2.7.15")
-    (replacement python-2/fixed)
     (source
      (origin
       (method url-fetch)
@@ -108,7 +107,9 @@
                                "python-2-deterministic-build-info.patch"
                                "python-2.7-site-prefixes.patch"
                                "python-2.7-source-date-epoch.patch"
-                               "python-2.7-adjust-tests.patch"))
+                               "python-2.7-adjust-tests.patch"
+                               "python2-CVE-2018-14647.patch"
+                               "python2-CVE-2018-1000802.patch"))
       (modules '((guix build utils)))
       ;; suboptimal to delete failing tests here, but if we delete them in the
       ;; arguments then we need to make sure to strip out that phase when it
@@ -266,16 +267,6 @@ data types.")
 ;; Current 2.x version.
 (define-public python-2 python-2.7)
 
-(define python-2/fixed
-  (package
-    (inherit python-2)
-    (source (origin
-              (inherit (package-source python-2))
-              (patches (append
-                        (origin-patches (package-source python-2))
-                        (search-patches "python2-CVE-2018-14647.patch"
-                                        "python2-CVE-2018-1000802.patch")))))))
-
 (define-public python2-called-python
   ;; Both 2.x and 3.x used to be called "python".  In commit
   ;; a7714d42de2c3082f3609d1e63c83d703fb39cf9 (March 2018), we renamed the