summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2017-12-04 17:56:37 -0500
committerKei Kebreau <kkebreau@posteo.net>2017-12-22 11:49:43 -0500
commit9e3a8ed0ebc5b4095f1b64d85fd56ce7fb636580 (patch)
tree361eb76581a93690fb84003548ccf1a5a5726e05 /gnu/packages/python.scm
parent3a1f26ff75d5032f402b5bb95c579ced37492f10 (diff)
downloadguix-9e3a8ed0ebc5b4095f1b64d85fd56ce7fb636580.tar.gz
gnu: python-pillow: Update to 4.3.0.
* gnu/packages/python.scm (python-pillow): Update to 4.3.0.
[propagated-inputs]: Add python-olefile.
* gnu/packages/patches/python-pillow-freetype-2.7-test-failure.patch:
Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Signed-off-by: Kei Kebreau <kkebreau@posteo.net>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d3bd2078b0..9fd7d9f6be 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3686,15 +3686,14 @@ the OleFileIO module from PIL, the Python Image Library.")
 (define-public python-pillow
   (package
     (name "python-pillow")
-    (version "3.3.3")
+    (version "4.3.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Pillow" version))
-       (patches (search-patches "python-pillow-freetype-2.7-test-failure.patch"))
        (sha256
         (base32
-         "0xkv0p1d73gz0a1qaasf0ai4262g8f334j07vd60bjrxs2wr3nmj"))))
+         "09xmn7rl6840sli2iz1k3fgxfgmri2nqz6vkinmb9mgg8ifp2z59"))))
     (build-system python-build-system)
     (native-inputs
      `(("python-nose"       ,python-nose)))
@@ -3706,6 +3705,8 @@ the OleFileIO module from PIL, the Python Image Library.")
        ("openjpeg" ,openjpeg)
        ("libtiff"  ,libtiff)
        ("libwebp"  ,libwebp)))
+    (propagated-inputs
+     `(("python-olefile" ,python-olefile)))
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-after