summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-06-12 16:03:43 -0400
committerLeo Famulari <leo@famulari.name>2018-07-19 18:28:29 -0400
commitc69d11c593036b4c188824f6b595bfe88bc46aca (patch)
treed4db34ee2ad20e8ae211ac7b9c8ef6a46fd100a0 /gnu/packages/python.scm
parent79d4d47b99591e4edd8cefee907fbb0d930f78aa (diff)
downloadguix-c69d11c593036b4c188824f6b595bfe88bc46aca.tar.gz
gnu: Cython: Update to 0.28.4.
* gnu/packages/python.scm (python-cython, python2-cython): Update to 0.28.4.
[arguments]: Use invoke.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 642d7529b6..a984670f6e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2850,14 +2850,14 @@ and is very extensible.")
 (define-public python-cython
   (package
     (name "python-cython")
-    (version "0.27")
+    (version "0.28.4")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Cython" version))
        (sha256
         (base32
-         "02y0pp1nx77b8s1mpxc6da2dccl6wd31pp4ksi9via479qcvacmr"))))
+         "0imw9s2rbrh32clbl10csnwmig9p3nzkrd2baxxxfmnrsc42pb3n"))))
     (build-system python-build-system)
     ;; we need the full python package and not just the python-wrapper
     ;; because we need libpython3.3m.so
@@ -2870,7 +2870,7 @@ and is very extensible.")
            ;; some tests require access to "$HOME/.cython"
            (lambda _ (setenv "HOME" "/tmp") #t))
          (replace 'check
-           (lambda _ (zero? (system* "python" "runtests.py" "-vv")))))))
+           (lambda _ (invoke "python" "runtests.py" "-vv"))))))
     (home-page "http://cython.org/")
     (synopsis "C extensions for Python")
     (description "Cython is an optimising static compiler for both the Python