summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-04 20:45:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-04 22:47:15 +0300
commit0adc21c2933fbe47ee37d90acdb4ad8cbc60ed69 (patch)
tree7d411a230260196592945b45cc5c255c7912553b /gnu/packages/python.scm
parentfa8af53e99afd932b2e534a428ea6ac62581c89d (diff)
downloadguix-0adc21c2933fbe47ee37d90acdb4ad8cbc60ed69.tar.gz
gnu: Add python2-pytest-cache.
* gnu/packages/python.scm (python2-pytest-cache): New variable.
(python-pytest-cache)[properties]: New field.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 49f0b88020..3505f36b4c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7091,7 +7091,17 @@ minimal and fast API targetting the following uses:
     (description "The pytest-cache plugin provides tools to rerun failures from
 the last py.test invocation.")
     (home-page "https://bitbucket.org/hpk42/pytest-cache/")
-    (license license:expat)))
+    (license license:expat)
+    (properties `((python2-variant . ,(delay python2-pytest-cache))))))
+
+(define-public python2-pytest-cache
+  (let ((pytest-cache (package-with-python2
+                        (strip-python2-variant python-pytest-cache))))
+    (package
+      (inherit pytest-cache)
+      (native-inputs
+       `(("python2-setuptools" ,python2-setuptools)
+         ,@(package-native-inputs pytest-cache))))))
 
 (define-public python-pytest-localserver
   (package