summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-10-21 23:12:17 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-25 22:25:20 -0700
commit7d4147634bca68d38dfc7b7edaf38c7c85029986 (patch)
tree852dd1dca5bafb5524d77c2bbb49677147acb836 /gnu/packages/python.scm
parent2a81537f2fe20f1d65222606c97a62ec84a557b8 (diff)
downloadguix-7d4147634bca68d38dfc7b7edaf38c7c85029986.tar.gz
gnu: Add python-verboselogs.
* gnu/packages/python.scm (python-verboselogs, python2-verboselogs): New
variables.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2b2457f978..106b23e902 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1157,6 +1157,32 @@ for additional processing.")
 (define-public python2-capturer
   (package-with-python2 python-capturer))
 
+(define-public python-verboselogs
+  (package
+    (name "python-verboselogs")
+    (version "1.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "verboselogs" version))
+       (sha256
+        (base32
+         "09z4d1jiasn7k1hs5af2ckmnrd0i1d1m04bhfjhv7z6svzfdwgg3"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-mock" ,python-mock)
+       ("python-astroid" ,python-astroid)
+       ("python-pylint" ,python-pylint)))
+    (home-page "https://verboselogs.readthedocs.io")
+    (synopsis "Verbose logging level for Python's logging module")
+    (description
+     "The @code{verboselogs} package extends Python's @code{logging} module to
+add the log levels NOTICE, SPAM, SUCCESS and VERBOSE.")
+    (license license:expat)))
+
+(define-public python2-verboselogs
+  (package-with-python2 python-verboselogs))
+
 (define-public python-eventlet
   (package
     (name "python-eventlet")