summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-26 02:39:15 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-26 02:39:15 +0100
commit2115bde3024b685087af70a20d7846498d6c9985 (patch)
treecc6d1ea429091c6c64824fc95991a36b6831e607 /gnu/packages/python.scm
parentf58764d8ed633a8ad1c9f2578be7bbde36ed7ce7 (diff)
downloadguix-2115bde3024b685087af70a20d7846498d6c9985.tar.gz
gnu: python-parse: Update to 1.8.2.
* gnu/packages/patches/python-parse-too-many-fields.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/python.scm (python-parse): Update to 1.8.2.
[source](patches): Remove.
[arguments]: Use INVOKE instead of SYSTEM*.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3c816cda53..14a79a9b22 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1431,21 +1431,20 @@ backported for previous versions of Python from 2.4 to 3.3.")
 (define-public python-parse
   (package
     (name "python-parse")
-    (version "1.6.6")
+    (version "1.8.2")
     (source
      (origin
       (method url-fetch)
       (uri (pypi-uri "parse" version))
       (sha256
        (base32
-        "0y31i3mwgv35qn0kzzjn9q8jqfdqmbi6sr6yfvn8rq4lqjm5lhvi"))
-      (patches (search-patches "python-parse-too-many-fields.patch"))))
+        "1lj9v1q4imszyhvipb6drsm3xdl35nan011mqxxas1yaypixsj40"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _ (zero? (system* "python" "test_parse.py")))))))
+           (lambda _ (invoke "python" "test_parse.py"))))))
     (home-page "https://github.com/r1chardj0n3s/parse")
     (synopsis "Parse strings")
     (description