summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-02-27 08:37:28 -0500
committerMark H Weaver <mhw@netris.org>2016-02-27 08:49:26 -0500
commitb35461748b20d0172744974b39e7d9d033400c51 (patch)
treefc06c3fbb4a9d95186289064f6f6196d50023362 /gnu/packages/python.scm
parent48766ea85fa6009759ad52db30852d5e5580f12e (diff)
downloadguix-b35461748b20d0172744974b39e7d9d033400c51.tar.gz
gnu: Fix misplaced commas (unquote).
Fix many occurrences of comma (unquote) being placed immediately after the
previous list item, e.g. ("ncurses", ncurses) in the inputs.

* gnu/packages/base.scm (patch, gnu-make),
  gnu/packages/bioinformatics.scm (hmmer),
  gnu/packages/bittorrent.scm (aria2),
  gnu/packages/compression.scm (pbzip2),
  gnu/packages/databases.scm (recutils),
  gnu/packages/fonts.scm (font-terminus),
  gnu/packages/freedesktop.scm (xdg-utils, elogind),
  gnu/packages/games.scm (gnujump),
  gnu/packages/gnome.scm (libidl, gnumeric, eog, gedit),
  gnu/packages/gnunet.scm (gnunet),
  gnu/packages/gnuzilla.scm (mozjs, nspr),
  gnu/packages/gtk.scm (gtksourceview, gdk-pixbuf),
  gnu/packages/lua.scm (lua),
  gnu/packages/openstack.scm (python-swiftclient),
  gnu/packages/perl.scm (perl-json-any),
  gnu/packages/polkit.scm (polkit-qt),
  gnu/packages/python.scm (wrap-python3, python-oauthlib)
  (python-mccabe-0.2.1, python-contextlib2, python2-rauth),
  gnu/packages/qt.scm (qtkeychain),
  gnu/packages/ruby.scm (ruby-nokogiri),
  gnu/packages/screen.scm (screen),
  gnu/packages/ssh.scm (libssh),
  gnu/packages/video.scm (ffmpeg, mplayer),
  gnu/packages/vim.scm (vim),
  gnu/packages/xdisorg.scm (redshift),
  gnu/packages/xfce.scm (xfce4-panel, xfce4-settings),
  gnu/packages/xnee.scm (xnee),
  gnu/packages/xorg.scm (font-adobe100dpi, font-adobe75dpi),
  gnu/packages/zsh.scm (zsh): Fix misplaced commas (unquote).
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b67aed05f7..2441220901 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -332,8 +332,8 @@ data types.")
                   (lambda (old new)
                     (symlink (string-append python old)
                              (string-append bin "/" new)))
-                  `("python3", "pydoc3", "idle3")
-                  `("python",  "pydoc",  "idle"))))))
+                  `("python3" ,"pydoc3" ,"idle3")
+                  `("python"  ,"pydoc"  ,"idle"))))))
     (synopsis "Wrapper for the Python 3 commands")
     (description
      "This package provides wrappers for the commands of Python@tie{}3.x such
@@ -2347,7 +2347,7 @@ somewhat intelligeble.")
     (build-system python-build-system)
     (native-inputs
      `(("python-setuptools" ,python-setuptools)
-       ("python-coverage", python-coverage)
+       ("python-coverage" ,python-coverage)
        ("python-nose" ,python-nose)
        ("python-mock" ,python-mock)))
     (inputs
@@ -5142,7 +5142,7 @@ complexity of Python source code.")
         (sha256
           (base32
             "0fi4a81kr5bcv5p4xgibqr595hyj5dafkqgsmfk96mfy8w71fajs"))))
-    (inputs `(("python-setuptools", python-setuptools)))))
+    (inputs `(("python-setuptools" ,python-setuptools)))))
 
 (define-public python2-mccabe-0.2.1
   (package-with-python2 python-mccabe-0.2.1))
@@ -6753,7 +6753,7 @@ of the SSL peer.")
          (replace 'check
            (lambda _ (zero?
                       (system*
-                       "python" "test_contextlib2.py", "-v")))))))
+                       "python" "test_contextlib2.py" "-v")))))))
     (home-page "http://contextlib2.readthedocs.org/")
     (synopsis "Tools for decorators and context managers")
     (description "This module is primarily a backport of the Python
@@ -7247,7 +7247,7 @@ authenticated session objects providing things like keep-alive.")
     (package (inherit rauth)
       (propagated-inputs `(("python2-requests" ,python2-requests)))
       (native-inputs
-       `(("python2-unittest2", python2-unittest2)
+       `(("python2-unittest2" ,python2-unittest2)
          ,@(package-native-inputs rauth))))))
 
 (define-public python2-functools32