summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-09-16 23:02:11 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-09-20 04:29:10 +0200
commit350ba0a32b6d21acb974a1715d60df7839fd5acc (patch)
treeb863efa322443ed9ca7dca627b5bda50e6cd1974 /gnu/packages/python.scm
parenta5002ae77c00693792ae0024b290cc24fb1d4328 (diff)
downloadguix-350ba0a32b6d21acb974a1715d60df7839fd5acc.tar.gz
gnu: Add python-prettytable
* gnu/packages/python.scm (python-prettytable,
  python2-prettytable): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 408064d9be..1818993399 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4880,3 +4880,31 @@ object to help create WSGI responses.")
 
 (define-public python2-webob
   (package-with-python2 python-webob))
+
+(define-public python-prettytable
+  (package
+    (name "python-prettytable")
+    (version "0.7.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/P/PrettyTable/"
+             "prettytable-" version ".tar.bz2"))
+       (sha256
+        (base32
+         "0diwsicwmiq2cpzpxri7cyl5fmsvicafw6nfqf6p6p322dji2g45"))))
+    (build-system python-build-system)
+    (inputs
+      `(("python-setuptools" ,python-setuptools)))
+    (home-page "http://code.google.com/p/prettytable/")
+    (synopsis "Display tabular data in an ASCII table format")
+    (description
+      "A library designed to represent tabular data in visually appealing ASCII
+tables.  PrettyTable allows for selection of which columns are to be printed,
+independent alignment of columns (left or right justified or centred) and
+printing of sub-tables by specifying a row range.")
+    (license bsd-3)))
+
+(define-public python2-prettytable
+  (package-with-python2 python-prettytable))