summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@gnu.org>2018-04-16 11:04:19 +0200
committerTomáš Čech <sleep_walker@gnu.org>2018-04-21 08:33:34 +0200
commit15ed90b96008e7c91f89c03854b49af05dd17e99 (patch)
treef453763e9892355ee30e36dd86ee03b07e2ae618 /gnu/packages/python.scm
parentb5178b325409b1eaf953f8f3007a180cbd27b167 (diff)
downloadguix-15ed90b96008e7c91f89c03854b49af05dd17e99.tar.gz
gnu: Add python-onetimepass.
* gnu/packages/python.scm (python-onetimepass): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ae6e38f024..c033123a35 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -50,6 +50,7 @@
 ;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
 ;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
 ;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
+;;; Copyright © 2016, 2018 Tomáš Čech <sleep_walker@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -13126,3 +13127,21 @@ file system events on Linux.")
     (description "Pybtex is a BibTeX-compatible bibliography processor written
 in Python.  You can simply type pybtex instead of bibtex.")
     (license license:expat)))
+
+(define-public python-onetimepass
+  (package
+    (name "python-onetimepass")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "onetimepass" version))
+       (sha256
+        (base32 "09vagxgbq78wvq4xbikmn2hpqqsa2i96kqsmphf7dqynfv0dlsd5"))))
+    (build-system python-build-system)
+    (inputs `(("python-six" ,python-six)))
+    (home-page "https://github.com/tadeck/onetimepass/")
+    (synopsis "One-time password library")
+    (description "Python one-time password library for HMAC-based (HOTP) and
+time-based (TOTP) passwords.")
+    (license license:expat)))