summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-29 23:56:03 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:59:00 +0100
commit5f1000d5d4cc4dfc9a1fe220457c17ad011d9e33 (patch)
tree6b2e328bd002b20c9d90191d0fde2aa484a29fb4 /gnu/packages/python.scm
parent8aeac338a7084720a0143f54b83e39d18a2edcdc (diff)
downloadguix-5f1000d5d4cc4dfc9a1fe220457c17ad011d9e33.tar.gz
gnu: libffi: Update to 3.3.
* gnu/packages/patches/libffi-3.2.1-complex-alpha.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/libffi.scm (libffi): Update to 3.3.
[source](patches): Remove.
* gnu/packages/python.scm (python-3.7)[arguments]: Remove workaround.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 43b4044e72..ef1c8e4a09 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -377,12 +377,7 @@ data types.")
                 " --exclude test_mmap"
                 ;; test_socket may hang and eventually run out of memory
                 ;; on some systems: <https://bugs.python.org/issue34587>.
-                " test_socket"
-                ;; XXX: test_ctypes fails on some platforms due to a problem in
-                ;; libffi 3.2.1: <https://bugs.python.org/issue23249>.
-                ,@(if (string-prefix? "aarch64" (%current-system))
-                      '(" test_ctypes")
-                      '()))))
+                " test_socket")))
        ((#:phases phases)
        `(modify-phases ,phases
           (add-before 'check 'set-TZDIR