summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-04-10 00:19:20 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-04-10 00:19:46 +0200
commit08c045091e8d8da3b4c677540ed577e8f2448b0d (patch)
tree758fb076b865fd48cd66ac853fc6def34c32fe72 /gnu/packages/python.scm
parent2bfe74378cbd1ebb4ae511f70daa3019723acbb7 (diff)
downloadguix-08c045091e8d8da3b4c677540ed577e8f2448b0d.tar.gz
python: Update to 3.4.3
* gnu/packages/python.scm (python): Update from 3.3.5 to 3.4.3.
* gnu/packages/patches/python-fix-tests.patch: Update the required test fixes.
* gnu/packages/patches/python-libffi-mips-n32-fix.patch: Remove it...
* gnu-system.am (dist_patch_DATA): ... and do not reference it here.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 59c460af3b..2381c7d2c7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -201,18 +201,16 @@ data types.")
 
 (define-public python
   (package (inherit python-2)
-    (version "3.3.5")
+    (version "3.4.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.python.org/ftp/python/"
                                   version "/Python-" version ".tar.xz"))
-              (patches (list (search-patch "python-fix-tests.patch")
-                             (search-patch "python-sqlite-3.8.4-test-fix.patch")
-                             (search-patch "python-libffi-mips-n32-fix.patch")))
+              (patches (list (search-patch "python-fix-tests.patch")))
               (patch-flags '("-p0"))
               (sha256
                (base32
-                "1rdncc7g8g6f3lfdg33rli1yffbiq8z283xy4f5ksl1l8i49psdb"))))
+                "1f4nm4z08sy0kqwisvv95l02crv6dyysdmx44p1mz3bn6csrdcxm"))))
     (arguments (substitute-keyword-arguments (package-arguments python-2)
                  ((#:tests? _) #t)))
     (native-search-paths